PHP Composer install

I’m in a console with a ssh connection to a server.
Now I have a clone of my project from git.

If I do the following thing: php composer.phar install I get the next error:

  • Getting code from my forked repository
  • How do I get Composer to download the latest commit in the master branch from GitHub for a package?
  • Composer - Forked Laravel 4.2 not installing
  • Modifying Symfony composer vendors and using them until their PR is merged
  • Composer installs TCPDF with .git repository
  • how do I version my composer package
  • Loading composer repositories with package information
    Installing dependencies from lock file
    Your requirements could not be resolved to an installable set of packages.
    
      Problem 1
        - Installation request for doctrine/doctrine-bundle dev-master -> satisfiable by doctrine/doctrine-bundle dev-master.
        - doctrine/doctrine-bundle dev-master requires jdorn/sql-formatter >=1.1,<2.0 -> no matching package found.
      Problem 2
        - Installation request for doctrine/doctrine-bundle 1.0.x-dev -> satisfiable by doctrine/doctrine-bundle 1.0.x-dev.
        - doctrine/doctrine-bundle 1.0.x-dev requires jdorn/sql-formatter >=1.1,<2.0 -> no matching package found.
      Problem 3
        - Installation request for zendframework/zend-i18n 2.0.5 -> satisfiable by zendframework/zend-i18n 2.0.5.
        - zendframework/zend-i18n 2.0.5 requires ext-intl * -> the requested PHP extension intl is missing from your system.
      Problem 4
        - zendframework/zend-i18n 2.0.5 requires ext-intl * -> the requested PHP extension intl is missing from your system.
        - zendframework/zend-validator 2.0.5 requires zendframework/zend-i18n 2.0.5 -> satisfiable by zendframework/zend-i18n 2.0.5.
        - Installation request for zendframework/zend-validator 2.0.5 -> satisfiable by zendframework/zend-validator 2.0.5.
    
    Potential causes:
     - A typo in the package name
     - The package is not available in a stable-enough version according to your minimum-stability setting
       see <https://groups.google.com/d/topic/composer-dev/_g3ASeIFlrc/discussion> for more details.
    
    Read <http://getcomposer.org/doc/articles/troubleshooting.md> for further common problems.
    

    My composer.js:

    {
        "name": "symfony/framework-standard-edition",
        "description": "The \"Symfony Standard Edition\" distribution",
        "autoload": {
            "psr-0": { "": "src/" }
        },
        "require": {
            "php": ">=5.3.3",
            "symfony/symfony": "2.1.*",
            "doctrine/orm": ">=2.2.3,<2.4-dev",
            "doctrine/doctrine-bundle": "1.0.*",
            "twig/extensions": "1.0.*",
            "symfony/assetic-bundle": "2.1.*",
            "symfony/swiftmailer-bundle": "2.1.*",
            "symfony/monolog-bundle": "2.1.*",
            "sensio/distribution-bundle": "2.1.*",
            "sensio/framework-extra-bundle": "2.1.*",
            "sensio/generator-bundle": "2.1.*",
            "jms/security-extra-bundle": "1.2.*",
            "jms/di-extra-bundle": "1.1.*",
            "friendsofsymfony/user-bundle": "*",
            "friendsofsymfony/jsrouting-bundle": "1.0.*",
            "mv/name1-bundle" : "*",
            "mv/name2-bundle" : "*",
            "psliwa/pdf-bundle": "*"
        },
        "scripts": {
            "post-install-cmd": [
                "Sensio\\Bundle\\DistributionBundle\\Composer\\ScriptHandler::buildBootstrap",
                "Sensio\\Bundle\\DistributionBundle\\Composer\\ScriptHandler::clearCache",
                "Sensio\\Bundle\\DistributionBundle\\Composer\\ScriptHandler::installAssets",
                "Sensio\\Bundle\\DistributionBundle\\Composer\\ScriptHandler::installRequirementsFile"
            ],
            "post-update-cmd": [
                "Sensio\\Bundle\\DistributionBundle\\Composer\\ScriptHandler::buildBootstrap",
                "Sensio\\Bundle\\DistributionBundle\\Composer\\ScriptHandler::clearCache",
                "Sensio\\Bundle\\DistributionBundle\\Composer\\ScriptHandler::installAssets",
                "Sensio\\Bundle\\DistributionBundle\\Composer\\ScriptHandler::installRequirementsFile"
            ]
        },
        "repositories": [
            {
                "type": "vcs",
                "url": "git@bitbucket.org:name1/name1bundle.git"
            },
            {
                "type": "vcs",
                "url": "git@bitbucket.org:name2/name2bundle.git"
            },
            {
                "type": "composer",
                "url": "http://packages.zendframework.com/"
            },
            {
                "type": "composer",
                "url": "http://packagist.org/"
            }
        ],
        "minimum-stability": "dev",
        "extra": {
            "symfony-app-dir": "app",
            "symfony-web-dir": "public_html",
            "symfony-assets-install": "symlink"
        }
    }
    

    The strange thing is, local it works like a charm! but on the server it gives me errors. What is the problem and how to solve this?

    Oh and I can’t do php composer.phar update (extern hosted server)

    Loading composer repositories with package information
    Updating dependencies                                 
    
    Fatal error: Allowed memory size of 536870912 bytes exhausted (tried to allocate 71 bytes) in phar:///composer.phar/src/Composer/DependencyResolver/RuleWatchGraph.php on line 47
    

    Thnx.

  • Git: Set up a fetch-only remote?
  • How to reset the origin/master ref locally
  • git staging server
  • Why is a Git post-commit hook on non-interactive rebase not run?
  • Git checkout no longer warns of unchanged files
  • How to set difftool/mergetool for a specific file extension in Git?
  • One Solution collect form web for “PHP Composer install”

    wget the newest composer.phar to make sure you’re on the safe side there. Or even better you can do:

    php composer.phar self-update
    

    Problems 1 and 2 most likely have some illegal notation for versions. Try adding the jdorn/sql-formatter package directly to your own requirements with a specific version number.

    Problems 3 and 4 have nothing to do with composer. The PHP extension intl is not installed on your system but it’s a required dependency of some ZF2 components. Which means you need to install it or compile it into PHP on your server.

    Git Baby is a git and github fan, let's start git clone.