libiconv.2.dylib Mountain Lion issue

Anytime I’m try to install something git dependent (homebrew for example) I get this error:

> Incompatible library version: git requires version 8.0.0 or later, but
> libiconv.2.dylib provides version 7.0.0

I’ve reinstalled git and xcode but the error keeps being thrown. I don’t have macports installed.

  • Pitfalls when upgrading to a new version of Git
  • Update pre_commit hook file on version control
  • How do I check for uncommitted git repositories in windows
  • How create a project-fork with git (no github fork!) and keep relation to original repository
  • Why “git pull” command over https from github repository need “sudo” as prefix?
  • Newbie in Heroku: Error when push my app to Heroku
  • Anyone have ideas on how to solve?

  • In Libgit2sharp, is there any way to revert some files' change (Not commited)?
  • How to work around “multiple merge bases” error in EGit Eclipse plugin?
  • GitBash generally slow
  • vim cd'ing to git root
  • Allow two users to commit with their usernames on the same machine
  • Jenkins - how to build a specific branch
  • Git Baby is a git and github fan, let's start git clone.