git-upload-pack not found while adding new repository to Eclipse Git

I use Eclipse with GIT plugin. I try to add a new GitHub repository, by copying the GitHub URL to the clipboard, then going to the “Git Repositories” view and right-clicking “Paste Repository Path or URL”.

I get the following error:

  • Need help configuring external diff with Eclipse
  • Why did the GitHub windows client delete all of my work?
  • Best git structure for importing android dependent project with egit in eclipse
  • Eclipse is trying to build the files in my .svn directories… how can I tell it to stop?
  • Howto re-attach subclipse when using a new Eclipse on an existing workspace
  • Exporting a local EGit repo to local GitStack repo
  • not found

    This is strange, because I already have some repositories in this view…

  • Always add commit author and date in TortoiseGit
  • Can I rebase and squash commits at the same time?
  • git rebase: copy instead of moving
  • Is there a trick to git log --follow a directory which has been renamed?
  • How to compile forked library in Gradle?
  • Check-ins to TFS2013 source control triggers CI build associated with separate TFS Git Repository
  • 2 Solutions collect form web for “git-upload-pack not found while adding new repository to Eclipse Git”

    From Erel’s answer to my question in the comment section, it turned out the mistake was the copy of the wrong url. So, instead of copying the url provided by github, Erel copied the url in the navigation bar. The solution was to change the repository address to

    For users of EGit/Eclipse who get the same error when clone from Visual Studio Online, be careful
    the repo URL is not:

    the correct one is:

    Git Baby is a git and github fan, let's start git clone.