Firefox os Gaia on osx 10.5.8 make error

I try to install Gaia using mozilla instructions

OSX : 10.5.8
Xcode : 3.1.4
Git : git-1.7.5.4-i386-leopard

  • Validation error while submitting app to Firefox Marketplace
  • $ cd ~/ffos/
    $ git clone git://github.com/mozilla-b2g/gaia.git gaia
    Cloning into gaia...
    remote: Counting objects: 110061, done.
    remote: Compressing objects: 100% (31997/31997), done.
    remote: Total 110061 (delta 78367), reused 106338 (delta 75377)
    Receiving objects: 100% (110061/110061), 294.06 MiB | 846 KiB/s, done.
    Resolving deltas: 100% (78367/78367), done.
    $ cd gaia/
    $ DEBUG=1 make
    rm -rf xulrunner-sdk /usr/bin/curl -O http://ftp.mozilla.org/pub/mozilla.org/xulrunner/nightly/2012/09/2012-09-20-03-05-43-mozilla-central/xulrunner-18.0a1.en-US.mac-x86_64.sdk.tar.bz2
      % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                     Dload  Upload   Total   Spent    Left  Speed
    100 54.2M  100 54.2M    0     0   527k      0  0:01:45  0:01:45 --:--:--  590k
    tar xjf xulrunner*.tar.bz2 && rm xulrunner*.tar.bz2
    test -d profile || mkdir -p profile
    run-js-command  applications-data
    dyld: unknown required load command 0x80000022
    /bin/bash: line 1:   439 Trace/BPT trap          ./xulrunner-sdk/bin/run-mozilla.sh ./xulrunner-sdk/bin/xpcshell -e "$JS_CONSTS" -f build/utils.js "build/applications-data.js"
    make: *** [applications-data] Error 133
    

    i found this article, but it’s the same :
    http://sebastian.germes.in/blog/2012/04/dyld-unknown-required-load-command-0x80000022-tracebpt-trap/

    if someone have idea for my probleme.

  • Github error while trying to push
  • git grep--but restricted to new or modified files in the index
  • How to resolve a conflict with git-svn?
  • Find common ancestor of two git branches
  • Jenkins on OS X Local Git Repository URL
  • How to import a git repository as a subdirectory of another git repository without losing any commit?
  • One Solution collect form web for “Firefox os Gaia on osx 10.5.8 make error”

    You may need to install node.js to run js commands …

    Git Baby is a git and github fan, let's start git clone.