Failed to deploy artifacts

When I try to deploy my application, I got this error:

[ERROR] Failed to execute goal org.apache.maven.plugins:maven-deploy-plugin:2.7:deploy (default-deploy) on project acme-db: Failed to deploy artifacts: Could not transfer artifact com.acme:acme-db:jar:0.8.1 from/to artifactory.acme.com (http://artifactory.acme.com/libs-release-local): Access denied to: http://artifactory.acme.com/libs-release-local/com/acme/acme-db/0.8.1/acme-db-0.8.1.jar, ReasonPhrase:Forbidden. -> [Help 1]
[ERROR] 
[ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.
[ERROR] Re-run Maven using the -X switch to enable full debug logging.
[ERROR] 
[ERROR] For more information about the errors and possible solutions, please read the following articles:
[ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/MojoExecutionException
Build step 'Invoke top-level Maven targets' marked build as failure
Finished: FAILURE

  • Jenkins + Gradle + Artifactory: Couldn't read generated build info
  • Building multiple Maven profiles for a single Jenkins job
  • Jenkins Running on Websphere 8.5 causes plugin class load errors
  • Delete jenkins builds during Promote / promotion step
  • Getting Artifactory Plugin to work with Jenkins and Maven
  • How to set Artifactory discardOldBuilds to true in a Jenkinsfile?
  • POSTing file to Jenkins fails
  • Jenkins CI with chef
  • Jenkins windows slave service does not interact with desktop
  • Package contains object and package with same name
  • What environment variables are passed go Jenkins when using the Gerrit Trigger Plugin?
  • How to install plugins in jenkins, with the help of jenkins remote access API?
  • 2 Solutions collect form web for “Failed to deploy artifacts”

    You have to verify your credentials in MAVEN_HOME/conf/settings.xml section servers

    <server>
      <id>nexus</id>
      <username>deploy</username>
      <password>123456</password>
    </server>
    

    Id must match with id in distribution management in your pom.xml

    <distributionManagement>
        <repository>
            <id>nexus</id>
            <url>...</url>
        </repository>
    </distributionManagement>
    

    The cause of this problem seemed to be this:

    Access denied to: http://artifactory.acme.com/libs-release-local/com/acme/acme-db/0.8.1/acme-db-0.8.1.jar, ReasonPhrase:Forbidden. -> [Help 1]
    
    Git Baby is a git and github fan, let's start git clone.