Eclipse forget my Git password and username everytime after I do a push

Eclipse Platform Version: 4.3.2.v20140221-1852 Build id: M20140221-1700

Eclipse Git Version: 3.3.2.201403251439

  • SVN for ClearCase user. How to use?
  • which eclipse project/workspace files should be added to source control?
  • Linphone Android Import and Build
  • GitHub for Windows push/pull, results in Eclipse infinite refresh loop
  • Is there any reason NOT to use git-masquerading-as-cvs as an upgrade to cvs?
  • SVN Switch with relocate in Eclipse
  • Eclipse forgets my git username and password every time after I do a push. What is the problem?

    I have tried the methods in How to make Egit remember password and username?:

    1) Go to the Git Perspective -> Expand your Project -> Expand Remotes -> Expand the remote you want to save your password.

    2) Right-click on the Fetch or Push -> Select Change Credentials…

    3) Enter username and password -> Select Ok

    But it did not work for me. My problem is that Eclipse can temporarily remember my username and password as shown in the following figure:

    enter image description here

    But after I do a push, Eclipse will forget all the Credentials (username and password):

    enter image description here
    enter image description here

    Eclipse asks me for the username and password every time I do a push even if the first figure shows it has temporarily remembered my password.

    enter image description here
    enter image description here

    Helps would be much appreciated.

  • What's the meaning of `()` in git command SYNOPSIS?
  • How can you automatically remove trailing whitespace in vim
  • git untracked files - how to ignore/delete
  • Cannot push from user repository to master repository located on NAS
  • IntelliJ git fetch pruned remote references
  • how to git pull/fetch local repo from remote where cloned with --share --bare
  • One Solution collect form web for “Eclipse forget my Git password and username everytime after I do a push”

    I got the problem myself. It should be a bug in the version of Eclipse Git I was using. When I updated to the latest Eclipse Git, the problem is solved!

    Git Baby is a git and github fan, let's start git clone.