dyld: unknown required load command 0x80000022 error with Git installation

I am running Mac OS X 10.5.8 and downloaded the git-1.8.2.3-intel-snow-leopard.dmg of Git. I ran the installation pkg on the disk, it finished installation but now everytime I type git in the terminal it throws the error:

dyld: unknown required load command 0x80000022
Trace/BPT Trap

  • How to fix git config issue where all commands go to blank line?
  • How do you stash only files that have been added?
  • GIT: remove remote branches with no local tracking branch
  • Identify obsolete branches when commits have been squashed
  • What happens to old commits after you use `git commit --amend`?
  • Git push origin master getting 'origin' doesn't appear to be a git repository
  • Untrack folder locally in git and push to production without deleting
  • How to Bash Script Git Local Branch Check?
  • Embedding a patch to a custom Linuxbrew formula
  • How can I share local commits to my TFS 2017 server from a submodule hosted in github?
  • git not pushing all files within folder
  • Git: move changes between branches without working directory change
  • Git Baby is a git and github fan, let's start git clone.