An error occurred while installing sqlite3 (1.3.11), and Bundler cannot continue

So im trying to $ bundle install --without production before I $ git push heroku masterbut i keep getting this error

$ bundle install --without production
Fetching gem metadata from https://rubygems.org/............
Fetching version metadata from https://rubygems.org/...
Fetching dependency metadata from https://rubygems.org/..
Resolving dependencies......
Using rake 10.4.2
Using i18n 0.7.0
Using json 1.8.3
Using minitest 5.8.3
Using thread_safe 0.3.5
Using tzinfo 1.2.2
Using activesupport 4.1.8
Using builder 3.2.2
Using erubis 2.7.0
Using actionview 4.1.8
Using rack 1.5.5
Using rack-test 0.6.3
Using actionpack 4.1.8
Using mime-types 2.99
Using mail 2.6.3
Using actionmailer 4.1.8
Using activemodel 4.1.8
Using arel 5.0.1.20140414130214
Using activerecord 4.1.8
Using execjs 2.6.0
Using autoprefixer-rails 6.1.2
Using sass 3.2.19
Using bootstrap-sass 3.3.5
Using bundler 1.10.6
Using coffee-script-source 1.10.0
Using coffee-script 2.4.1
Using thor 0.19.1
Using railties 4.1.8
Using coffee-rails 4.0.1
Using hike 1.2.3
Using multi_json 1.11.2
Using jbuilder 2.3.2
Using jquery-rails 3.1.4
Using tilt 1.4.1
Using sprockets 2.12.4
Using sprockets-rails 2.3.3
Using rails 4.1.8
Using rdoc 4.2.0
Using sass-rails 4.0.5
Using sdoc 0.4.1
Installing sqlite3 1.3.11 with native extensions
C:/jruby-9.0.0.0/lib/ruby/stdlib/rubygems/ext/ext_conf_builder.rb:39: warning: Tempfile#unlink or delete called on open file; ignoring

Gem::Ext::BuildError: ERROR: Failed to build gem native extension.

    C:/jruby-9.0.0.0/bin/jruby.exe -r ./siteconf20151208-25620-qipdd0.rb extconf.rb
NotImplementedError: C extensions are not supported
    <top> at C:/jruby-9.0.0.0/lib/ruby/stdlib/mkmf.rb:1
  require at org/jruby/RubyKernel.java:940
   (root) at C:/jruby-9.0.0.0/lib/ruby/stdlib/rubygems/core_ext/kernel_require.rb:1
    <top> at extconf.rb:3

extconf failed, exit code 1

Gem files will remain installed in C:/jruby-9.0.0.0/lib/ruby/gems/shared/gems/sqlite3-1.3.11 for inspection.
Results logged to C:/jruby-9.0.0.0/lib/ruby/gems/shared/extensions/universal-java-1.8/2.2.0/sqlite3-1.3.11/gem_make.out
An error occurred while installing sqlite3 (1.3.11), and Bundler cannot
continue.
Make sure that `gem install sqlite3 -v '1.3.11'` succeeds before bundling.

this is my Gemfile

  • Bower “Git not in the PATH” error
  • How can I make git do the “did you mean” suggestion?
  • What are the pros and cons of git submodule and Repo?
  • git cloning behind proxy — different behavior, same command
  • Why is git log --cherry-pick not removing equivalent commits?
  • How to set up tortoisegit to not require password using ssh
  • source 'https://rubygems.org'
    
    gem 'rails', '4.1.8'
    gem 'sass-rails', '~> 4.0.3'
    gem 'uglifier', '>= 1.3.0'
    gem 'coffee-rails', '~> 4.0.0'
    gem 'jquery-rails'
    gem 'turbolinks'
    gem 'jbuilder', '~> 2.0'
    gem 'bootstrap-sass'
    
    
    
    group :development, :test do
     gem 'sqlite3'
    end
    
    group :production do
     gem 'pg'
     gem 'rails_12factor'
    end
    
    group :doc do
        gem 'sdoc', require: false
    end
    

    I tried to

    gem uninstall sqlite3
    gem install sqlite
    

    But i got

    $ gem install sqlite3
    Building native extensions.  This could take a while...
    C:/jruby-9.0.0.0/lib/ruby/stdlib/rubygems/ext/ext_conf_builder.rb:39: warning: Tempfile#unlink or delete called on open file; ignoring
    ERROR:  Error installing sqlite3:
            ERROR: Failed to build gem native extension.
    
        C:/jruby-9.0.0.0/bin/jruby.exe -r ./siteconf20151208-19428-iytd2g.rb extconf.rb
    NotImplementedError: C extensions are not supported
        <top> at C:/jruby-9.0.0.0/lib/ruby/stdlib/mkmf.rb:1
      require at org/jruby/RubyKernel.java:940
       (root) at C:/jruby-9.0.0.0/lib/ruby/stdlib/rubygems/core_ext/kernel_require.rb:1
        <top> at extconf.rb:3
    
    extconf failed, exit code 1
    
    Gem files will remain installed in C:/jruby-9.0.0.0/lib/ruby/gems/shared/gems/sqlite3-1.3.11 for inspection.
    Results logged to C:/jruby-9.0.0.0/lib/ruby/gems/shared/extensions/universal-java-1.8/2.2.0/sqlite3-1.3.11/gem_make.out
    

    Does any one have any ideas to what could be causing this?

  • Is there a mercurial equivalent to gits no-fast-forward merge?
  • Using an alternate diff algorithm in Git
  • How can I find the second parent of a searched commit in git?
  • What VCS allows me to add changes to multiple pending commits simultaneously?
  • Problem connecting to GitHub on Windows, even via PuTTY
  • Why is this git shallow clone bigger than I expected?
  • 4 Solutions collect form web for “An error occurred while installing sqlite3 (1.3.11), and Bundler cannot continue”

    As benjamin said, you need to install the sqlite3 database before you can install the sqlite3 gem. It looks like you are on Windows, so try following the instructions listed here:

    How do I install sqlite3 for Ruby on Windows?

    For reference, here is the accepted answer on that thread, by user Williams:

    1. Install the Ruby Devkit for your setup (DevKit-mingw64-64-4.7.2-20130224-1432-sfx.exe for me since I use a x64 machine)

    2. Download and extract the autoconf package from Sqlite.org

    3. Run msys.bat (it is inside the ruby devkit root folder)

    4. cd into the path where you downloaded the sqlite source (for example: “cd /c/dev/sqlite3” for path “c:\dev\sqlite3” if you are new to MSYS/MINGW32)

    5. Run “./configure”

    6. Run “make”

    7. Run “make install”

    8. Get the sqlite3 gem again, this time specifying the platform and the path to the newly compiled binaries:

      gem install sqlite3 --platform=ruby -- --with-sqlite3-include=[path\to\sqlite3.h] --with-sqlite3-lib=[path\to\sqlite3.o]

      For example:

      gem install sqlite3 --platform=ruby -- --with-sqlite3-include=/c:/dev/sqlite3/ --with-sqlite3-lib=/c:/dev/sqlite3/.libs/

      (from the paths given in step 4)

    9. Check the Gemfile.lock of your rails app and make sure that it points to the correct sqlite3 version. Mine was “sqlite3 (1.3.7-x86-mingw32)” and manually changed it to “sqlite3 (1.3.7-x64-mingw32)”. Removing the platform also works: “sqlite3 (1.3.7)”.

    Good luck!

    I think you need to install sqlite3 and sqlite3-dev first.

    sudo apt-get install -y sqlite3 libsqlite3-dev
    

    Have a try, might solve your problem

    You have to install the sqlite3 database for your operating system, preferably through the tool your OS provides. After doing this, try installing the gem again. Chances are you have to resolve similar errors by the same procedure.

    This might helps. I got the same problem, I searched a lot and now I solved this. This is maybe just about sqlite3’s version

    you should do this first

    sudo apt-get install -y sqlite3 libsqlite3-dev

    then open your Gemfile and change the line of sqlite3 to

    gem ‘sqlite3’, ‘~> 1.3’, ‘>= 1.3.11’

    then run

    bundle install

    I hope this will help you as it helped me.

    Git Baby is a git and github fan, let's start git clone.